[#23020] Firefox disabled the Picker because it could not be verified

Problem

Firefox disabled the Picker with the message "Citavi Picker could not be verified for use in Firefox."

Cause

Firefox Version 43 and later blocks the installation of unverified add-ons.

Solution

In Citavi 5.2 and later the Picker for Firefox is verified. If you still receive the message above if you're working with a later version of Citavi, your Picker failed to update.
 
Please take these steps:
  1. Uninstall the Picker for Firefox via the Windows Control Panel (see below).
  2. Download the Picker from the Mozilla store:
    https://addons.mozilla.org/en-US/firefox/addon/citavi-picker
    Click Add to Firefox > Install > Restart Firefox.
To uninstall the Citavi Picker:
  1. On the Windows Control Panel, click Programs and features > Citavi [Version]
  2. Click Change. The Setup Assistant appears. Click Next.
  3. Select Modify, and then click Next.
  4. Click the hard drive icon next to Picker for Firefox and select the option This feature will not be available:

  5. Click Next and continue through the Setup Assistant.